Error on uploading attachment for some users: "API-1007: You are not authorized to process this request"

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Article ID: 209005

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

Non admin users cannot upload file attachments to a child object of Project, but only in the Modern UX
 
They get the error:  "API-1007: You are not authorized to process this request"
 
Steps to Reproduce
 
1- In Studio, create a new object called: "Client" that has "Project" as its Master Object
 
2- API  enabled =  Yes
3- Add the following Attributes. The important one is the Attachment Data Type
4- Save and Return
 
5- Continue to the Views Tab, select "General" > "Layout Edit"
Include the "Client Attachment" attribute
 
6- "Publish"
7- Open a Project in the classic UI and go to the Properties tab drop down and select "Client List"
8- Create a new Client and notice that it will allow you to upload a file attachment
 
This does not work in the Modern UX
 
9- Login to the Modern UX
10- Administration > Blueprints
11- Edit or copy an existing blueprint
12- Under the Modules tab, click Edit
13- Bring over the "Clients" module
 
14- Publish
15- On the Blueprint List form, http://serverName/pm/#/admin/blueprints
drag over an existing Template to the Blueprint you just created
16- Go to "Projects"
17- Create a new Project From Template (selecting the one you modified)
18- Go to the "Clients" tab and click the plus sign to create a new client
The same user can upload attachments to "Clients" in Classic, but not in the Modern UX

Cause

This is caused by a defect with the permissions in the Modern UX when a user only has instance level rights to the sub object.

Environment

Release : 15.9.1

Component : CA PPM SAAS STUDIO

Resolution

This is being tracked under Defect: DE59856

Additional Information

Workaround: Assign Edit Global level Access rights to the object for the user.

Attachments