Symantec Protection Engine on Linux install fails: This copy of the Symantec Protection Engine component(CAF) software did not install correctly
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Symantec Protection Engine on Linux install fails: This copy of the Symantec Protection Engine component(CAF) software did not install correctly

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Article ID: 209000

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Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Installing Symantec Protection Engine (SPE) on Linux fails with the following error message:

ERROR:  This copy of the Symantec Protection Engine component(CAF)
software did not install correctly.
Review the error or warning messages that were issued, take
the corrective action suggested, then try again.

Checking the install log at /var/log/SYMCScan-install.log shows an error similar to the following (version number may differ):

Uninstalling existing Symantec Data Center Security Common Agent Framework
Installing new Symantec Data Center Security Common Agent Framework
        package sdcss-caf-2.0.1-86.x86_64 is already installed

ERROR:  This copy of the Symantec Protection Engine component(CAF)
software did not install correctly.
Review the error or warning messages that were issued, take
the corrective action suggested, then try again.

Attempting to manually uninstall the cafagent with rpm -e sdcss-caf fails with an error similar to the following (again, version number may differ):

[root@localhost ~]# rpm -e sdcss-caf


Aborting uninstall as CAF Agent does not seem to be installed correctly.
File "/opt/Symantec/cafagent/lib/instfunlib" is inaccessible, or is missing.
If protection is enabled, it must be disabled before uninstalling.
Otherwise, a manual uninstall must be performed to remove this software.
Refer to product documentation to perform a Manual Uninstall.


error: %preun(sdcss-caf-2.0.1-86.x86_64) scriptlet failed, exit status 1​
error: sdcss-caf-2.0.1-86.x86_64: erase failed

/opt/Symantec/ does not exist.

Environment

SPE 8.0+ on Linux

Cause

Necessary files for the pre-uninstall scriptlet that reside in /opt/Symantec/ do not exist, causing rpm to be unable to uninstall the CAF component of SPE. This could have happened if an attempt was made to remove a Symantec product using rm -rf /opt/Symantec.

Resolution

Remove the cafagent installation without scripts:

rpm -ev --noscripts sdcss-caf

Then attempt to install SPE again.