Does Advanced Authention support HTTP 1.1?

book

Article ID: 208965

calendar_today

Updated On:

Products

CA Strong Authentication

Issue/Introduction

Symantec Adapter libraries for Siteminder integration use HTTP 1.0 to interact with ArcotSM.

This doesn't work in customer's production environment, where WAFs block HTTP < 1.1.

When using Siteminder Adapter shim authentication, users get the error "unable to retrieve token".

 

 

Cause

Adapter shim has used HTTP 1.0 while creating a token with State Manager.

Environment

Release : 9.1 SP1

Component : Strong Authentication (Arcot WebFort)

Resolution

For HTTP 1.1 support, Hotfix CA-SiteMinderAdapter-9.1.01-DE486825-Hotfix needs to applied on top of 9.1SP1 and it will be available in next release for all customers.