Unable to Login to API Gateway using Policy Manager after Upgrade to V10 due to jdk 8u172
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Unable to Login to API Gateway using Policy Manager after Upgrade to V10 due to jdk 8u172

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Article ID: 208842

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Updated On:

Products

CA Mobile API Gateway CA API Gateway STARTER PACK-7

Issue/Introduction

It's software gateway, after upgrade from gateway 9.4 to gateway 10, the gateway keeps in STARTING status and the policy manager cannot connect to the gateway.

Environment

Release : 4.2

Component : MOBILE API

Cause

The current jdk is jdk-8u172-linux-x64.rpm.

As per document,

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/release-notes/requirements-and-compatibility/software-gateway-specifications.html

It requires at least OpenJDK 8u242-b08

Resolution

  1. yum install java-1.8.0-openjdk-devel-1.8.0.275.b01-0.el7_9.x86_64
  2. configure new jdk path for gateway as per KB 8508, https://knowledge.broadcom.com/external/article/8508/unable-to-start-software-gateway-after-u.html
  3. restart gateway

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/layer7-api-management/api-gateway/10-0/release-notes/requirements-and-compatibility/software-gateway-specifications.html

https://knowledge.broadcom.com/external/article/8508/unable-to-start-software-gateway-after-u.html