Why persistent alarms are re-generated, losing Acknowledged, Trouble Ticket ID, Assignment, and Status info
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Why persistent alarms are re-generated, losing Acknowledged, Trouble Ticket ID, Assignment, and Status info

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Article ID: 208735

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

After restarting the SpectroSERVER, all the existing alarms with Acknowledged, Assignment, Trouble Ticked ID, and Status information are lost, and new alarms were generated, even though they are persistent alarms.

Based on the following section of the Spectrum guide, the alarm information such as Acknowledged, Assignment, Trouble Ticked ID, and Status information should be retained:

TechDocs : DX NetOps Spectrum 24.3 : Working with Events and Alarms

Specify Alarm Options

You can specify the following advanced options for an alarm:
    • Alarm is Persistent

      If this option is selected, the alarm is retained in memory, in case the SpectroSERVER is shut down and restarted.

Environment

DX NetOps Spectrum all currently supported releases

Cause

The SSdb database was restored. The ssEvents.db, ssEvents.ix, ssAlarms.db, and ssAlarms.ix files are not saved in the SSdb backup.

Resolution

One possible workaround would be making a backup of the ssAlarms.db and ssAlarms.ix files from the $SPECROOT/SS/ directory before the SSdb restore, while the SpectroSERVER is down.

Once the SSdb restore has finished, copy back the ssAlarms.db and ssAlarms.ix files.

Another option would be establishing a Fault-Tolerant Environment.

See the following section of the Spectrum guide about SpectroSERVER Alarm Synchronization for further details:

TechDocs : DX NetOps Spectrum 24.3 : SpectroSERVER Alarm Synchronization

Additional Information