UIM - Unable to retrieve data metrics from snmpcollector probe

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Article ID: 208567

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Updated On:

Products

DX Infrastructure Management

Issue/Introduction

In the Inventory tab, the metrics aren't displayed anymore. It seems that all devices metrics from the snmpcollector (pollagent) got lost from OC-UIM20.3.2 dashboard

But some metrics, such as net_connect/cdm are still visible.

 

 

 

Cause

There might have been a SnmpProxy network issue and suddenly stop polling information, or corruption in the snmpcollector Database. 
The snpmcollector configuration ( so all the info for polling the devices) is stored in some H2 Database files located in : C:\Program Files (x86)\Nimsoft\probes\network\snmpcollector
So it is possible that the database got corrupt and this is compatible with it working again after wiping the DB files off.

Environment

Component : UNIFIED INFRASTRUCTURE MGMT

UIM 20.3.2. Hub 9.32HF2

OC 20.3.2, ump_dashboard_hf2

Resolution

• Remove the entire snmpcollector probe, together with all the folders.
• Reinstall the snmpcollector probe and restart the UIM server.

Note:
After deleting the probe and redeploying it a fresh DB file will be created. This won't include any previously discovered devices so you will need to reimport the devices from the discovery server or rediscover the device manually:

• If needed copy the template back over and import the devices from the discovery probe.