Log rotation anomaly
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Log rotation anomaly

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Article ID: 208555

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Updated On:

Products

DX Application Performance Management APM CA Application Performance Management (APM / Wily / Introscope) CA Application Performance Management Agent (APM / Wily / Introscope)

Issue/Introduction

 

The log rotation does not work correctly and logs appear with a special name that does not rotate.

The rotation and naming of logs normally follows this behaviour:
IntroscopeAgent.myAgent.log
IntroscopeAgent.myAgent.log.1
IntroscopeAgent.myAgent.log.2
....

But sometimes  the word "old" is created and this log does not rotate correctly. For example:
IntroscopeAgent.myAgent.old.log

What is the explanation for this ?

Environment

Release : 10.7.0

Component : APM Agents

Cause

 

This is intentional behaviour of the agent.

 

When the agent starts up, it creates a temporary startup log file with the filename format IntroscopeAgent.YYYYMMSS-HHmmss.log.

Eventually the log file will be renamed to match the determined name of the agent.

When the renaming happens, there is a coded limit of 256kB for this log to be allowed to be appended to an existing log file of the same name or a new log file to be created.

If the file is above the limit of 256kB, this is where the log cannot be rotated and the word 'old' will be added to the file. It will still have the determined name of the agent.

If there is already an 'old' log of the same name in the agent folder, there will be an old_1, old_2 log file created to avoid file name conflict.

 

The initial log file could be large due to extra (DEBUG) messages in the log file, or extra time taken for the agent to determine its name.

Resolution

 

Files with 'old' in them can be reviewed for investigation and removed at no risk.