PM - activemq.service failing to start after installing the Data Aggregator
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PM - activemq.service failing to start after installing the Data Aggregator

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Article ID: 208446

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

After trying to install the DA using a sudo user on /IMDataAggregator/scripts/activemq directory and having some problems, it was decided to uninstall this instance of the DA and perform a new installation on a different path, this time on /opt/application/CA/ImDataAggregator. Now, it looks like the activemq sevice is failing to start:

Redirecting to /bin/systemctl status activemq.service
● activemq.service - Apache ActiveMQ
   Loaded: loaded (/etc/systemd/system/activemq.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2021-02-10 14:20:39 CET; 18min ago
  Process: 17659 ExecStart=/opt/IMDataAggregator/scripts/activemq start sysd (code=exited, status=203/EXEC)

Feb 10 14:20:39 sldclr1131.app.gen.local systemd[1]: Starting Apache ActiveMQ...
Feb 10 14:20:39 sldclr1131.app.gen.local systemd[1]: activemq.service: control process exited, code=exited status=203
Feb 10 14:20:39 sldclr1131.app.gen.local systemd[1]: Failed to start Apache ActiveMQ.
Feb 10 14:20:39 sldclr1131.app.gen.local systemd[1]: Unit activemq.service entered failed state.
Feb 10 14:20:39 sldclr1131.app.gen.local systemd[1]: activemq.service failed.
Hint: Some lines were ellipsized, use -l to show in full.```"

Environment

Any release

Cause

For this particular case it looks like it failed to get rid of old service file and didn't lay down a new one with new location information.

Resolution

In order to address this issue please do the following:

- Navigate to /etc/systemd/system/ directory and open the activemq.service file
- See if you have the correct path and update it to the correct location:

[Unit]
Description=Apache ActiveMQ
After=syslog.target

[Service]
User=root
Type=forking
ExecStart=/opt/IMDataAggregator/scripts/activemq start sysd
ExecStop=/opt/IMDataAggregator/scripts/activemq stop sysd

[Install]
WantedBy=multi-user.target


- Run the following commands:
systemctl daemon-reload
sudo systemctl start activemq

This should resolve this issue otherwise please open a case with Broadcom Support