This article addresses an issue where Unix v2 password changes loop and fail with an 'expirationDate value has an unexpected format' error in the Java Connector Server (JCS) logs. This occurs specifically when the 'Account expires' attribute is enabled for the account.
Identity Manager 14.x
The JCS requires the host server’s system date and time format to be set to 'English (US)'. If the host server uses a different regional format, JCS fails to correctly interpret the expiration date from the endpoint, causing the password change process to loop.
To resolve this issue, you must update the system account regional format on the server running the JCS service:
To speak with a customer representative or a Support Engineer see . Scroll to the bottom of the page and click on your respective region.