Resolution for 'expirationDate value has an unexpected format' Error in JCS - Identity Manager
search cancel

Resolution for 'expirationDate value has an unexpected format' Error in JCS - Identity Manager

book

Article ID: 208444

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

This article addresses an issue where Unix v2 password changes loop and fail with an 'expirationDate value has an unexpected format' error in the Java Connector Server (JCS) logs. This occurs specifically when the 'Account expires' attribute is enabled for the account.

Environment

Identity Manager 14.x

Cause

The JCS requires the host server’s system date and time format to be set to 'English (US)'. If the host server uses a different regional format, JCS fails to correctly interpret the expiration date from the endpoint, causing the password change process to loop.

Resolution

To resolve this issue, you must update the system account regional format on the server running the JCS service:

Configure Regional Settings

  1. Open Control Panel > Region.
  2. On the Format tab, select English (US) from the drop-down list and click Apply.
  3. Select the Administrative tab and click Copy settings within the 'Welcome screen and new user accounts' section.
  4. Enable the checkbox for Welcome screen and system accounts at the bottom of the window.
  5. Verify that the 'Format' displayed in this screen has updated to English (US), then click OK twice.
  6. Restart the Connector Server (Java) service."

Additional Information

To speak with a customer representative or a Support Engineer see Contact Support. Scroll to the bottom of the page and click on your respective region.