Identity Manager Management Console, Directories and Environments, does not work
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Identity Manager Management Console, Directories and Environments, does not work

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Article ID: 208414

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Updated On:

Products

CA Identity Suite

Issue/Introduction

When the user tries to access the "Directories" or "Environments" from the Identity Manager Management Console, the URL is the following:
http://nameserver:port/iam/dir!listDirs

In the Identity Manager log we have the following message:
"GET /iam/dir!listDirs HTTP/1.1" 404 192 "http://nameserver:9080/iam/immanage?" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 10.0; WOW64; Trident/7.0; .NET4.0C; .NET4.0E; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729)"

 

This cause the Identity Manager Management Console not able to access the Directory and/or Environments links

Environment

Identity Manager 14.x on Websphere 8.5.x

Cause

As we can see the URL does not have the "immanage", if we add "immanage" to URL (http://nameserver:port/iam/immanage/dir!listDirs) it works without problems.

The root cause was the Websphere that does not have the redirecting context configured.

Resolution

This is not an Identity Manager issue, but a Websphere configuration issue.

 

1. Navigate to this are in WAS admin console:

That is Application servers > server1 > Web container > Custom properties

You need to add the property below, if it does not exist, and set it to true:

       com.ibm.ws.webcontainer.redirectcontextroot

 

After that, restart the whole cluster