MQ Service is not showing the delay in response time at client appe

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Article ID: 208381

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Updated On:

Products

CA Application Test

Issue/Introduction

MQ Virtual Service is set with 300ms think time in VSI and when seen the VS metrics reports it show as 300ms. However the call to the VS will happen via REST API using soapUI and the response time is showing as 20-40ms only.

 

 

Cause

Staled messages in Queues caused the issue.

Environment

Release : 10.6

Component : CA Application Test

Resolution

Performed the below steps which resolved the issue. 
 
. Stop IBM MQ Virtual Service
. Locate the proxy request and response queues and clear them from IBM MQ Explorer. This will ensure that the application that listens on these queues does not consume stale messages.
. Start VS.
 
Set the Think Time to 300 ms and seeing 305-325 ms after cleaning the queues.