Messaging Gateway mail delivery fails with "554 5.1.0" response code.

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Article ID: 208371

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Updated On:

Products

Messaging Gateway

Issue/Introduction

Outbound messages are not be delivered to one of more internet domains. Viewing the message audit logs for these messages shows a delivery failure with the following details:

554 5.1.0 hostname0x.senderdomain.com has no mx or a record

 

Cause

The downstream / remote mail server is refusing to accept the email message because the sender domain in the message From address has neither an MX or A record in the DNS.

Resolution

Since this issue stems from the refusal of the downstream mail server to accept message delivery, this issue is not the result of the SMG configuration but with the application which originally sent the email message. This issue may be addressed via either of the following:

  • Correct the configuration of the application sending the message so that the envelope and header From use an internet deliverable email address. Usually this can be achieved by using the organization's domain as the from address rather than the hostname of the sending application server i.e. senderdomain.com rather than hostname0x.senderdomain.com.
  • Configure an outbound address masquerade in the SMG Protocols > Address Masquerading to convert hostname0x.senderdomain.com to senderdomain.com

Ideally, the sending application should be corrected but if that is no possible, SMG can correct the undeliverable from address via a masquerade. If there are multiple application servers sending messages with undeliverable from addresses, each will need its own entry in the outbound address masquerade.

Please see the product documention accessble from the Help menu in the Control Center upper right corner for details on configuring the Address Masquerading feature.