Error: "An error has occurred while saving software product changes. Check server logs for detail" when trying to manage a software product
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Error: "An error has occurred while saving software product changes. Check server logs for detail" when trying to manage a software product

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Article ID: 208229

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Updated On:

Products

Software Management Solution

Issue/Introduction

You are trying to "manage software" from recently discovered ones and see the following error message in the NS log:

A software product matching the key of the one you are creating already exists

You are following these steps:

  1. Under the SMP Console, Go to Manage > Software
  2. Search for product and select specific version you want to manage
  3. It will take to the product with the “software component summary” box with button to "Manage this software"
  4. Press "Manage this software"
  5. Display “Manage Software Component – Define Product” window. Click Next
  6. It will allow you to select a product category with state "managed". Click  Next
  7. Display software name with “create” button, select Create

Environment

ITMS 8.x

Cause

Having 2 of the same software products already in place, and one is under "managed product" and the other is under "unmanaged software".

Resolution

Validate that you don't have two software products with the same name:

You can delete the duplicate one under "Unmanaged Software" and leave the one under "Managed Products".