The Notification Server rejects NSEs and the Sym Agents show as disconnected
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The Notification Server rejects NSEs and the Sym Agents show as disconnected

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Article ID: 208217

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Updated On:

Products

Client Management Suite

Issue/Introduction

Every few hours, the Notification Server fails to process NSEs and the Sym Agents show as disconnected.

The following error appears in the Notification Server (SMP) log files:

Operation 'Direct: Head' failed. 
Protocol: HTTPS 
Host: [Host FQDN:443]
Path: /altiris/NS/Agent/PostEvent.asp 
Connection Id: 4886.10236 
Communication profile Id: [GUID of Communication Profile] 
Throttling: 0 0 0 
Error type: HTTP error 
Error code: HTTP status 503: The service is temporarily overloaded (0x8FA101F7)

Environment

ITMS 8.x

Cause

In IIS, the Application Pool Queue Length Property was set to the default value of 1000.

The following is from the Microsoft document called,  ApplicationPool.QueueLength Property. The following is found under the section called "Remarks":

When the maximum number of requests in the queue has been reached, the service returns an out-of-service message (503: Service Unavailable) to any additional requests to the current application pool.

 

Resolution

Work with Microsoft as needed to Optimizing IIS Performance