Performance Center fails to start post upgrade change to sudo root install owner

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Article ID: 208194

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

Upgraded to DX NetOps Performance Center 20.2.7, After the upgrade the CAPC service does not start.

The DX NetOps Performance Management Performance Center server was running as a root owned installation.

It was configured to utilize port 443 for SSL HTTPS security.

During the upgrade the install owner was changed from root to a sudo root user.

After the upgrade the services fail to start.

Cause

On Linux systems only root users are able to utilize ports lower than port 1024. Any port lower than 1024 accessed by non-root users will be rejected.

As a result when it the services started as the sudo root user post upgrade, it failed to run when it was rejected in it's attempt to utilize port 443.

Environment

All supported DX NetOps Performance Management releases

Resolution

Reinstall Performance Center as a root user.

Reconfigure system to utilize a port higher than port 1024 for SSL HTTPS use.

Once that is set up the install can then be changed to a non-root sudo root installation owner user.