Submitted Timesheets Are Not Being Processed

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Article ID: 208137

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

There is a process that processed upon a timesheet update of Open to Submitted.
Once submitted, action items should go to the manager,  however in checking the Initiated Process instances, they are stuck in the Submitted state and never go to the 'Approved' status.

 

Cause

Based on example error found in BG log:

ERROR 2021-02-05 15:00:40,338 [Event Handler pool-5-thread-6] bpm.eventmgr (clarity:process_admin:xxxxxx:none) An error occurred while processing event Event{_messageId='31393429', _objectTypeCode='timesheet', _objectId=6789938, _eventCode='update', _userId=5408258, _timestamp=2021-02-05 15:00:40.147, _autoStartProcessed=false, _deleteEventProcessed=true, _pushingEngineProcessed=false}
java.lang.NullPointerException

This is an issue with the process engine.

Environment

Release : 15.9

Component : CA PPM SAAS BUSINESS PROCESS MANAGEMENT

Resolution

This is reported as DE58763, resolved in the release of 15.9.1.

 

Additional Information

As a workaround, restart BG services.