Users cannot log into XFlow upgrading to 17.3.03

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Article ID: 208125

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After migrating from a previous release of xFlow to xFlow 17.3 RU3, users are no longer able to log in, and logging is showing errors during the login attempts.

incidentMS.log:

ERROR - 2021-02-08 16:18:31 [c.ca.casm.framework.util.CasmFuture] - Exception occurred, see call stack for more details: userid ()
java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: Error : NO, AHD04199:An unexpected Database error occurred. Contact your administrator., 32632|domsrvr|_PjAAA
	at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:331)
	at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:346)
	at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:870)
	at java.base/java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:837)
	at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
Caused by: com.ca.casm.exception.CasmBaseException: Error : NO, AHD04199:An unexpected Database error occurred. Contact your administrator., 32632|domsrvr|_PjAAA
	at com.ca.casm.actor.SdmCreateObjectActor.recvmsg1(SdmCreateObjectActor.java:775)
	at com.ca.casm.actor.MdcActor$1.apply(MdcActor.java:213)
	at akka.actor.ActorCell$$anonfun$become$1.applyOrElse(ActorCell.scala:606)
	at akka.actor.Actor.aroundReceive(Actor.scala:517)
	at akka.actor.Actor.aroundReceive$(Actor.scala:515)

stdlog:

02/08 16:18:31.79 servername sqlagt:Audit_Log eve   29584 ERROR        orclclass.c           1313 SQL Statement Failed. ORA: 1722  Message: ORA-01722: invalid number 
02/08 16:18:31.79 servername sqlagt:Audit_Log eve   29584 ERROR        orclclass.c           1314 Clause (INSERT INTO casm_active_sessions ( access_key, access_token, cabi_sso_token, cat_domain_id, cat_domain_name, cat_login_domain, cat_parent_id, cat_role_id, contact_uuid, creation_dt, last_access_time, role_id, secret_key, tenant, id ) VALUES ( :val1 , :val2 , :val3 , :val4 , :val5 , :val6 , :val7 , :val8 , :val9 , :val10 , :val11 , :val12 , :val13 , :val14 , :val15 )) Input (<access_key:int>1981714516|<access_token:string>4681fc63018705dd878e0bfd71318bca011d90078dfc5fafa23db186c1fdd3c096b72a5efa620fb357beaefba2c63944d8e5966a3625e16c1d31add002b237bc|<cabi_sso_token:string>(NULL)|<cat_domain_id:string>Domain|<cat_domain_name:string>Domain|<cat_login_domain:string>Domain|<cat_parent_id:int>10001|<cat_role_id:string>spadministrator|<contact_uuid:uuid>F4C2A60100EA154695D233F90ABFFD21|<creation_dt:time>02/08/2021 16:18:31|<last_access_time:time>02/08/2021 16:18:31|<role_id:int>10002|<secret_key:string>(NULL)|<tenant:uuid>9E9D61E4647C01F5BB96001A4A20017B|<id:int>435853)
02/08 16:18:31.79 servername bpvirtdb_srvr          29567 ERROR        vdbmisc.c              688 Miscellaneous Database error occured :ORA-01722: invalid number 

Cause

The cat_domain_id field is supposed to be NVARCHAR2 in the casm_active_sessions table, but somehow it was as NUMBER.

See below the casm_active_sessions from an OOTB environment:

Environment

CA Service Management 17.3

Oracle database

Resolution

Engage the DBA team and change the field cat_domain_id to NVARCHAR2 manually.

IMPORTANT:

It is a workaround to fix the issue and allow end-users to log into XFlow again. The environment has to be review to make sure there is no side-effect or similar issue regarding other fields with different formats. If noticing similar issues, consider reinstalling the environment from scratch. Probably there will be other unexpected issues or behavior impacting end-users.

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