Robot inactive alarm but controller seems to be showing nothing wrong

book

Article ID: 208083

calendar_today

Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) DX Infrastructure Management CA Unified Infrastructure Management for z Systems CA Unified Infrastructure Management SaaS (Nimsoft / UIM) NIMSOFT PROBES

Issue/Introduction

We migrated our UIM to the new versión 20.3 (fresh install) with some hotfix and updates, meanwhile we have a problem with a robot that is showing the service is inactive several times every minute. In the admin console the device just stops and starts to show again, in the controller file we don't see anything else or any clue about the problem. We try restarting the services but the problem still occurs. The connection is working fine by the usually ports (48000-48050) and the service is running as root.

Environment

Release : 20.3

Component : UIM - ROBOT

Resolution

As per the controller log, you could see that 2 robots had been installed.

Check existing robot directories and paths.

--------------------------------------------------------------------------------------------------------
Jan 28 18:37:43:592 [140185924007744] Controller: ----- Robot controller 7.95 [Build 7.95.10273, Jun 22 2018] started -----
Jan 28 18:37:43:592 [140185924007744] Controller:  Name   = xxxxxxxx IP = 10.xxx.x.xxx, Port = 48000
Jan 28 18:37:43:592 [140185924007744] Controller:  OS     = UNIX / Linux / Linux 3.10.0-1127.18.2.el7.x86_64 #1 SMP Mon Jul 20 22:32:16 UTC 2020 x86_64
...
...
...
Jan 28 20:15:11:216 [140185924007744] Controller: Going down...
Jan 28 20:15:19:614 [140185924007744] Controller: Down
--------------------------------------------------------------------------------------------------------
Jan 28 20:15:25:674 [140381100709696] 0 Controller: ----- Robot controller 9.32 [Build 9.32.1556, Nov  5 2020] started -----
Jan 28 20:15:25:674 [140381100709696] 0 Controller:  Name   = xxxxxxxx IP = 10.xxx.x.xxx, Port = 48000
Jan 28 20:15:25:674 [140381100709696] 0 Controller:  OS     = UNIX / Linux / Linux 3.10.0-1127.18.2.el7.x86_64 #1 SMP Mon Jul 20 22:32:16 UTC 2020 x86_64
...
...
...
Jan 28 20:15:26:796 [140381100709696] 0 Controller: _ProcStart - Probe 'spooler' - starting
Jan 28 20:15:27:859 [140381100709696] 0 Controller: _ProcStart - Probe 'hdb' - starting
Jan 28 20:15:28:919 [140381100709696] 0 Controller: _ProcStart - Probe 'cdm' - starting

After customer uninstalled one of the robots, the monitoring began working.