Xflow doesn't work after Production SwingBox

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Article ID: 208049

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After a swing box migration of SDM, the xFlow install is not successfully working.

Cause

The given xFlow install may be corrupted.  Accessing the casm.conf.js will fail as the public dir under xFlow\APPS\Services\incidentmicroservice-17.0.479 may be non-existent.  There is also an .com.zerog.registry.xml which may be overriding the install attempts.

Environment

Release : 17.3

Component : SERVICE DESK MANAGER

Resolution

The xFlow install should be re-done.  Have the original install backed up, then uninstalled, then reinstalled.

Before reinstall, locate the .com.zerog.registry.xml

Linux:  /var/.com.zerog.registry.xml

Windows:  C:\Program Files\Zero G Registry\.com.zerog.registry.xml (this will be a hidden folder)

Have the com.zerog.registry.xml file renamed/deleted

In the backend database, set all entries in al_cdb_componentinstallstate for %xflow% and task.install_l1analystcore (under packageid) to "failed" on installationstate as well to try and force a reinstall.  Also remove the existing xflow install dir if present.

xFlow install re-attempt should be successful.