Post Transactions to Financials Job Not Processing New Transactions

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Article ID: 208016

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

There are transactions in the 'New' status in Administration > Invalid Transactions page that are not being picked up by the Post Transactions to Financials job.

Cause

There is an issue with the IMP_TRANSACTIONIMPORT.pac_imp_header_id

There could be a database sequencing issue.

Environment

Release : 15.8

Component : CA PPM APPLICATION

Resolution

select * from IMP_TRANSACTIONIMPORT where importstatus = 'N'
and transdate between 'DD-MMM-YYYY' and 'DD-MMM-YYYY'
order by importdate desc

When a transaction XOG occurs, 2 tables are populated:
a. IMP_TRANSACTIONIMPORT
b. PAC_IMP_TRANSIMPORT_HEADER

the groupId value set in the XOG will be propagated to
a. PAC_IMP_TRANSIMPORT_HEADER.id
b. IMP_TRANSACTIONIMPORT.pac_imp_header_id

Any error found while running PTF will set
a. PAC_IMP_TRANSIMPORT_HEADER.errorcode
b. PAC_IMP_TRANSIMPORT_HEADER.importstatus of that particular groupId.

Any further attempts to run the PTF job, the script looks at each groupId
and its corresponding PAC_IMP_TRANSIMPORT_HEADER.errorcode and will not process any of the transactions with the same groupId from IMP_TRANSACTIONIMPORT.
This is the reason we are still seeing the "New Transaction" status even after running PTF job.

 

 



Additional Information

Another cause would be due to issue in article: https://knowledge.broadcom.com/external/article?articleId=130919

1. Go to the Administration > Finance > Manage Matrix page

2. Select the matrix

3. Use the filter to check the resource or property needing to be validated for a matching rate.

If one does not exist, add a catchall row, a row denoted by selecting all * asterisks for the value.

4. Run the Post Transactions to Financials job.