CA PAM Client showing blank screen on Server 2016 Terminal Services
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CA PAM Client showing blank screen on Server 2016 Terminal Services

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Article ID: 208006

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

The CA PAM Client does not seem to be operational with terminal services for Server 2016.  Users only get a blank screen after launching the client and connecting to a PAM server. 

The same issue can happen with VDI PAM Client instance as well.

Environment

Release : 3.4.x, 4.0.x, 4.1.0

Component : PRIVILEGED ACCESS MANAGEMENT

Cause

The client installation folder and subfolders were not writable by the users. The server admin had assumed that the PAM client would write files to each user's AppData folder and users would not need Modify permissions under the installation folder in Program Files (x86).

Resolution

As of Feb 2021 the PAM client writes cache and temporary files into folders under the installation folder, not in users's AppData folders. Thus the users launching the client need to have Modify permissions on the installation folder and subfolders. Changing the folder permissions resolved the problem. This is not expected to change in the near future.