Error occured while retrieving the list of VSE servers -Could not lock User prefs.  Unix error code 24.
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Error occured while retrieving the list of VSE servers -Could not lock User prefs.  Unix error code 24.

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Article ID: 207989

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Updated On:

Products

Service Virtualization

Issue/Introduction

Getting messages like "An error occurred while retrieving the list of VSE servers. ." and  "Failed to load data from the virtual service environment: VSE. Make sure that VSE is running. ." when login to the DevTest portal even though the VSE service is running on the server fine.

Not sure what could have caused this but changed Java minor version from 1.8.0_261 to 1.8.0_271 on that machine and verified the jre folder under$DEVTEST_HOME and it's pointing to the updated Java version. 

Below is the information from VSE.log file:

2021-01-26 17:00:04,465Z (09:00) [Timer-0] INFO  System.out                     - Jan 26, 2021 9:00:04 AM java.util.prefs.FileSystemPreferences checkLockFile0ErrorCode
2021-01-26 17:00:04,465Z (09:00) [Timer-0] INFO  System.out                     - WARNING: Could not lock User prefs.  Unix error code 24.
2021-01-26 17:00:04,465Z (09:00) [Timer-0] INFO  System.out                     - Jan 26, 2021 9:00:04 AM java.util.prefs.FileSystemPreferences syncWorld
2021-01-26 17:00:04,465Z (09:00) [Timer-0] INFO  System.out                     - WARNING: Couldn't flush user prefs: java.util.prefs.BackingStoreException: Couldn't get file lock.
2021-01-26 17:00:10,186Z (09:00) [ServerRequestResponder 20] WARN  com.itko.lisa.net.RemoteMethodExec - InvocationTargetException on invoke getInetAddresses
java.lang.reflect.InvocationTargetException
 at sun.reflect.GeneratedMethodAccessor108.invoke(Unknown Source)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
 at java.lang.reflect.Method.invoke(Method.java:498)
 at com.itko.lisa.net.RemoteMethodExec.execute(RemoteMethodExec.java:57)
 at com.itko.lisa.net.ServerRequestHandler.processRMIMessage(ServerRequestHandler.java:533)
 at com.itko.lisa.net.ServerRequestHandler.access$600(ServerRequestHandler.java:70)
 at com.itko.lisa.net.ServerRequestHandler$5.run(ServerRequestHandler.java:451)
 at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
 at java.util.concurrent.FutureTask.run(FutureTask.java:266)
 at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
 at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
 at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.SocketException: Too many open files (Socket creation failed)
 at java.net.NetworkInterface.getAll(Native Method)
 at java.net.NetworkInterface.getNetworkInterfaces(NetworkInterface.java:355)
 at com.itko.util.network.NetworkUtil.getAddressList(NetworkUtil.java:125)
 at com.itko.util.network.NetworkUtil.getAddressList(NetworkUtil.java:117)
 at com.itko.lisa.coordinator.VirtualServiceEnvironmentImpl.getInetAddresses(VirtualServiceEnvironmentImpl.java:2850)
 ... 12 more

Environment

Release : 10.6 and newer

Component : CA Service Virtualization

Cause

Java Version 1.8.0_271 caused the issue.

Resolution

Found the article https://confluence.atlassian.com/bamkb/bamboo-is-encountering-too-many-open-files-errors-after-recent-java-jdk-update-due-to-socket-leak-1043905245.html where customer is having an issue with Java Version 1.8.0_271 and it is recommended to use 1.8.0_282 or downgrade from 1.8.0_271 which should resolve the issue.