Compatibility of PHP Agent and PHP 7.4 on lighttpd webserver

book

Article ID: 207958

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Getting a failed agent install. Our application dev team has an environment running PHP 7.4 on a Lighttpd webserver with fcgi. 

Since we don't have access to install the agent ourselves,  we involved our sys admins to install the agent. They received this error: 

"PHP Root : /usr/bin/php

PHP Version : 7.4.9

Installation Status : Failed

Reason : Unsupported version '7.4.9' of PHP found at /usr/bin."

The guide here indicates "GEN500000000000822.tar" is the correct installer for APM 10.7 implementation.

Would Fastcgi need to be replaced with Php-fpm for this implementation to work successfully? Or are their other options for moving forward?

Environment

Release : 10.7.0

Component : APM Agents

Resolution

10.7 PHP Agent does not support PHP 7.4.  However the 20.11 SaaS Agent does and has the ability to connect to a 10.7 environment following this KB.

https://knowledge.broadcom.com/external/article?articleId=142917