"Login failed" when trying to login to logging.jsp through Virtual Appliance
http://<IP address>/iam/im/logging.jsp
Environment
Release : 14.2, 14.3, 14.4 and 14.5
Component : CA IDENTITY SUITE (VIRTUAL APPLIANCE)
Cause
User not found to login to logging.jsp.
Resolution
Setup new user on vApp
1. Log in to the command-line interface as config user.
2. Run the following command:
sudo /opt/CA/wildfly-idm/bin/add-user.sh
3. Select option "b" (Application User) for the following question:
“What type of user do you wish to add?”
4. Respond with any one of the following options when asked to select a "Username":
Type any previously defined user to add access for an existing user.
Type a different username to create a user. A user can access the logging.jsp file only when the user is a member of the
IAMAdmin application group.
5. Type
IAMAdmin
for the following question:
”What groups do you want this user to belong to? (Please enter a comma separated list, or leave blank for none): ”
6. Type No for the following question:
Is this new user going to be used for one AS process to connect to another AS process? e.g. for a slave host controller connecting to the master or for a Remoting connection for server to server EJB calls.
You can now access the logging.jsp file using the following URL (replace “<IDM_NODE_ADDRESS>” with the IDM server IP address):
http://<IDM_NODE_ADDRESS>:8080/iam/im/logging.jsp
Additional Information
These steps are detailed under "Modify CA Identity Manager Application Log level"