Timesheet users landing on grey page when navigating to new UX

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Article ID: 207940

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

Problem Statement: Timesheet users opening new UX via menu Action link from classic Clarity are presented with a blank screen. 

Steps to Reproduce:

  1. Set up Clarity menu Action link (http://<clarityurl>/pm). Detailed documentation to create action link 
  2. Create a new user and grant that user Timesheets - Navigate right (no other new UX right)
  3. Login as the new user to Classic Clarity and click action link created on Step 1 

Expected Results: The user is routed directly to the Timesheets section of New UX and no error is shown

Actual Results: The user sees a page with an error message “You do not have permissions for the new user experience.” and then is rerouted to a grey page.

Cause

Clarity defect DE59668

Environment

Clarity 15.9.0 and onwards 

Resolution

The defect is fixed in upcoming release i.e. 16.0

Workarounds:

  1. Refresh the page in the browser again OR
  2. Create another action link which goes directly to Timesheet example http://<clarityurl>/pm/#/timesheets

Additional Information

Create a menu link to classic ppm to clarity