ORA-14400 Errors After Upgrading eHealth or Loading an ASCII Backup
search cancel

ORA-14400 Errors After Upgrading eHealth or Loading an ASCII Backup

book

Article ID: 20788

calendar_today

Updated On:

Products

CA eHealth

Issue/Introduction

Problem:

After upgrading to a new version of eHealth or loading an ASCII backup of the database, you may see the following error appear in the system log:

Error: 'Pgm nhiRegStats[Active]: Unable to execute 'insert /*append**/into NH_REG0 select * from nhgt_REG0' (ORA-14400: inserted partition key does not map to any partition)'

This document explains what causes the error and how to fix it.

Cause:

An attempt was made to insert a record into a Range or Composite Range object with a concatenated partition key that is beyond the concatenated partition boundary list of the last partition -OR- An attempt was made to insert a record into a List object with a partition key that did not match the literal values specified for any of the partitions.

Resolution:

Please follow the steps listed below to resolve these errors.

  1. Start sqlplus

    sqlplus NH_USER/NH_USER@NH_DB_CONNECT_STRING

    where NH_USER is the user name and password of the eHealth account and NH_DB_CONNECT_STRING is the value of the variable of the same name
  2. Run the following commands at the SQL> prompt

    begin
    nh_reg_process.setup;
    end;
    /
  3. Wait 15 minutes after step 2 completes, then run the following command from the SQL> prompt

    Select what,job from user_jobs;

    If successful, 4 rows of information should be returned:

    nh_reg_process.maintain_partitions;
    nh_reg_process.load_nh_date_time_dim;
    nh_reg_process.load_nh_date_dim;
    nh_regdata_schema.add_reg_partitions;
  4. Exit from sqlplus

    exit

Environment

Release: LHDEVC99000-6.3-eHealth-Live Health Upgrade Elements
Component: