We're getting a 503 error when sending javascript snippet info to AXA

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Article ID: 207788

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Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

Snippet from the har file:

"status": 503,
          "statusText": "Service Unavailable",

 

 

Cause

I see this in DxC log:

[scheduling-1] INFO c.c.a.c.p.j.ProfileRequestSchedular - Sending Request to fetch WhiteList Apps
[pool-2-thread-1] ERROR c.c.a.c.i.m.k.c.ConsumerRunner - Error executing the action for the message recieved from the topic:dxc
java.lang.NullPointerException: null
    at com.ca.apm.cxc.processor.cache.ProfileCache.addToCache(ProfileCache.java:77)
...

 

So the DxC ListApps request failed. Please first double check if the tenant id in the url is correct. And is AXA UI working fine?

Please also try restarting AXA DxC and ReadServer pod (axaservices-dxc-5d9dd68cb5 and axaservices-readserver-69bbbf49c6). If this didn't resolve it, then turn on DEBUG log and restart both pods and collect complete DEBUG logs.

For the axaservices-dxc pod log, please get both these 2 logs:

DigitalExperienceCollector.log  

axaIntegrationMessages.log

Environment

Release : 20.2

Component : APM Agents

Resolution

After restarting DXC and ReadServer pods, the Browser Agent is working as expected and we are now seeing EUE data in AXA UI.