CA Dataquery DQS805E Table not found error

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Article ID: 207574

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Updated On:

Products

CA Datacom/DB

Issue/Introduction

Hello - we have a Datacom DB table that does not show up in the list of tables for Dataquery. The table is cataloged in the CXX, but not available to Dataquery.

Please provide direction on how this can happen, and what we can do to resolve. 

 

Cause

At some point, the table or database was catalogued to the CXX, but was not Enabled.

 

Environment

Component : CA Dataquery for CA Datacom

 

Resolution

The most common reason that a table is not showing up in CA Dataquery is that it was not Enabled in the Datadictionary.

Generally, we recommend that when you catalog the table or database, you also enable it. In batch, this is done with transactions like this:

//SYSIN    DD  *                                         
-USR DATACOM-INSTALL,NEWUSER                             
+CPY DATABASE,SAMP-ACT-DB(T001,DD,PRIV),PROD             
+END                                                     
+UPD DATABASE,SAMP-ACT-DB(PROD,DD,PRIV)                  
1000 CATALOG                                             
1000 ENABLE                                              
+END                                                     
/*                                                       

In DDOL, when you enter the CATALOG command, you can immediately follow it with the ENABLE command in the same format.

Once the table or database has been Enabled, it should appear in the list.

 

Additional Information

As always, please contact Broadcom support for CA Datacom if you have further questions.