IP and Siteminder: Unable to open work list item in View my Work list "No items found"
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IP and Siteminder: Unable to open work list item in View my Work list "No items found"

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Article ID: 207439

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Updated On:

Products

CA Identity Manager CA Identity Portal

Issue/Introduction

Select single Worklists and they display properly.  If you click the back button in the browser and select the same worklist item you see the error:

Any other worklist items once this is displayed will return the same error.

Siteminder is being used. 

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Siteminder

Cause

Logs show:

-SM-{RC2}KCeDsQsGoqDVeGOmnI9DXYjgt4FHSvadaFShAU9vl3SW55QIdayNV8isUQMjfsUqm/JD6CfJkyxbxg4de5d1b1wtx7XePqRcrXPNZsL52CuiaKcRdsSV/p37OQUzGDL9y2KiE2UeydKybteT/jezIg==
06:10:22,619 WARN  [ims.ui] (ajp-/0.0.0.0:8009-2) Unable to determine user from SiteMinder token: No items found
06:10:22,635 WARN  [ims.ui] (ajp-/0.0.0.0:8009-2) Retrying with a newer version of the SMTOKEN.
06:10:22,775 INFO  [ims.ui.ConsolePageFilter] (ajp-/0.0.0.0:8009-2) dispatch=/app/index.jsp

Resolution

When you click back in the browser it removes your SMtoken and a new one is not assigned.  You must click "close" on each worklist item once opened to close it.  Using the close button retains your SMtoken so other worklist items will continue to work.  You must use the "close" button on each item opened when you want to close.  If you click "back" in your browser the SMtoken will be removed and any other items will fail.