UIM - Cannot select devices or groups in CABI Availability Reports

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Article ID: 207369

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Updated On:

Products

DX Infrastructure Management

Issue/Introduction

When trying to create a Device or Group Availability Report in CABI I can't see any device or group in the drop down menu under "Select Device". What am I missing? 

 

Cause

Possible causes:

1. The required QOS is not being gathered

2. Origin mismatch between user permissions in CABI and reports

Environment

Release : 20.3

Component : UIM - CABI

Resolution

1. The first thing to check is that the required data is gathered:

For Cabi Availability Report to work the following set of QOS are needed:

Check: Metrics for Availability Reports
https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/dashboards/ca-business-intelligence-dashboards/library-of-ca-business-intelligence-reports-for-ca-uim/availability-reports.html


The availability report requires the following metrics:
QOS_SERVICE_AVAILABILITY (This metric is fetched using the ICMP_Probe)

For Cloud and Virtual Devices, the Power State (Device up/Down status) is calculated using the following metrics:
Azure - QOS_AZURE_INSTANCE_POWER_STATE
Aws - QOS_AWS_INSTANCE_POWER_STATE
VMWare - QOS_VMWARE_INSTANCE_POWER_STATE
Nutanix - QOS_NUTANIX_INSTANCE_POWER_STATE
HyperV - QOS_HYPERV_INSTANCE_POWER_STATE
Openstack - QOS_OPENSTACK_INSTANCE_POWER_STATE

Note: for VMWARE Probe if QOS_VMWARE_INSTANCE_POWER_STATE is not found while configuring the probe the following QOS is needed:
QOS_VMWARE_VM_POWER_STATE

Only once these metrics are added to monitoring the Availability by Group or Device Reports will allowing data selection (it will allow device to be visible under the drop down menu)

To verify that data is already stored in the database the following queries can be ran:

Example for checking ICMP probe current data: 

a) Run:
select table_id,r_table from S_QOS_DATA where qos = 'QOS_SERVICE_AVAILABILITY' and probe = 'icmp'

Exmple result:
709216 RN_QOS_DATA_0225
102494 RN_QOS_DATA_0225
102586 RN_QOS_DATA_0225


b) Now run the following query using the previous query results: 

select * from <RN_QOS_DATA_0***> where table_id = <table_id> ORDER BY sampletime DESC

Example: 
select * from RN_QOS_DATA_0225 where table_id = 709216 ORDER BY sampletime DESC


If the result shows current data then you know that the data is being collected correctly:

Example result:
709216 2021-01-27 11:36:02.000 100.00 0.00 600.00 -3600

 


2) If the above is checked and, in the Availabilty Reports is still not possible to see devices then verify the following KB and steps:

UIM - Availability by Group or Device Reports not allowing data selection
https://knowledge.broadcom.com/external/article?articleId=131896

 

Additional Information

UIM - Availability by Group or Device Reports not allowing data selection
https://knowledge.broadcom.com/external/article?articleId=131896

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