CA View - DFHAC2001 Transaction 'SAR' not Recognized in Production After Upgrade Performed
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CA View - DFHAC2001 Transaction 'SAR' not Recognized in Production After Upgrade Performed

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Article ID: 207350

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Updated On:

Products

View

Issue/Introduction

CA View and Deliver were upgraded on the production system.

Users were unable to log on to the View database, in receiving error message:

 DFHAC2001 01/25/2021 07:39:35 Transaction  'SAR' is not recognized. Check that the transaction name is correct.

 

 

Environment

Release : 14.0

Component : CA View

Cause

The PLT startup deck should include:

DFHPLT TYPE=ENTRY,PROGRAM=DFHDELIM
DFHPLT TYPE=ENTRY,PROGRAM=ExxCINIT

In this instance, the client did not have the above statements in the PLT startup deck, and as a result, the ExxXSTSK subtask was not started.

Resolution

Programs to be automatically started during CICS start up and shut down should be listed in the program list table (PLT).

For use of View's XMS, the ExxCINIT program needs to be in the PLT startup deck, and the ExxCIEND program needs to be in the PLT shutdown deck.

Note: xx is the View release level, where xx=C2 for level 12.2 and xx=E0 for level 14.0.

The startup deck would include:

DFHPLT TYPE=ENTRY,PROGRAM=DFHDELIM
DFHPLT TYPE=ENTRY,PROGRAM=ExxCINIT

The shutdown deck would include:

DFHPLT TYPE=ENTRY,PROGRAM=ExxCIEND
DFHPLT TYPE=ENTRY,PROGRAM=DFHDELIM

The client added the needed statements to the PLT startup deck, the XMS task started as expected, and users were able to log on to View via their CICS transactions.