When installing SCM Client I see the error: Application “” could not be found in the registry
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When installing SCM Client I see the error: Application “” could not be found in the registry

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Article ID: 207308

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

After installing SCM Client, the Administrator Tool is working fine, but if I try to open Workbench, I get this error message:

In the log file referenced in the error message, I see:

!SESSION 2021-01-18 14:10:04.109 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -eclipse.keyring @user.home/.cascm/keyring.txt
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -eclipse.keyring @user.home/.cascm/keyring.txt!ENTRY org.eclipse.osgi 4 0 2021-01-18 14:10:06.045
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application “” could not be found in the registry. The applications available are: <list of Java applications>

 

 

 

Environment

Release : 13.0.3 and up

Component : CA Harvest Software Change Manager

Cause

Locate Workbench's config.ini file in folder %CA_SCM_HOME%\configuration folder and view this file in Notepad.  Look for the option "eclipse.application=".  If you don't see anything after the equals sign (=) that is what is causing the error message.  

Resolution

If you do not have a backup of this file, the best solution is to uninstall and reinstall SCM Client:

- Go to Control Panel -> Programs and uninstall Enterprise Communicator first, and then uninstall SCM Client
- Delete the %CA_SCM_HOME% folder, the C:\Users\<your userid\.cascm folder and the C:\Users\<your userid\.eclipse folder
- Run the installation again, making sure to 
  - Login to Windows with a user id that is a member of the local Administrator group
  - Right click on the setup.exe and click "Run as Administrator"