When installing SCM Client I see the error: Application “” could not be found in the registry

book

Article ID: 207308

calendar_today

Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

After installing SCM Client, the Administrator Tool is working fine, but if I try to open Workbench I get this error message:

In the log file referenced in the error message I see:

!SESSION 2021-01-18 14:10:04.109 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_131
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments:  -eclipse.keyring @user.home/.cascm/keyring.txt
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -eclipse.keyring @user.home/.cascm/keyring.txt!ENTRY org.eclipse.osgi 4 0 2021-01-18 14:10:06.045
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application “” could not be found in the registry. The applications available are: 
com.ca.harvest.workbench.workbench, org.eclipse.birt.report.engine.ReportExecutor, org.eclipse.e4.ui.workbench.swt.E4Application, org.eclipse.e4.ui.workbench.swt.GenTopic, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.EclipseGenerator, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.equinox.p2.reconciler.application, org.eclipse.equinox.p2.repository.repo2runnable, org.eclipse.equinox.p2.repository.metadataverifier, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.updatesite.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.UpdateSitePublisher, org.eclipse.equinox.p2.publisher.CategoryPublisher, org.eclipse.help.base.infocenterApplication, org.eclipse.help.base.helpApplication, org.eclipse.help.base.indexTool.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:248)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

 

 

 

Cause

Locate Workbench's config.ini file in folder %CA_SCM_HOME%\configuration folder and view this file in Notepad.  Look for the option "eclipse.application=".  If you don't see anything after the equals sign (=) that is what is causing the error message.  

Environment

Release : 13.0.3

Component : CA Harvest Software Change Manager

Resolution

If you do not have a backup of this file, the best solution is to uninstall and reinstall SCM Client:

- Go to Control Panel -> Programs and uninstall Enterprise Communicator first, and then uninstall SCM Client
- Delete the %CA_SCM_HOME% folder, the C:\Users\<your userid\.cascm folder and the C:\Users\<your userid\.eclipse folder
- Run the installation again, making sure to 
  - Login to Windows with a user id that is a member of the local Administrator group
  - Right click on the setup.exe and click "Run as Administrator"

Attachments