No metric data in Performance Center after a certain date
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No metric data in Performance Center after a certain date

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Article ID: 207293

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Updated On:

Products

CA Infrastructure Management

Issue/Introduction

– DA is up all PM processes are up not getting any current metrics in any dashboards other than ADA and NFA metrics

Tried rebooting PM and DA

karaf.log on Data Collectors are reporting that they aren't finding any SNMP profiles also

2021-01-22 15:52:15,654 | ERROR | adpool-thread-99 | SnmpCollector                    | .dm.snmp.collector.SnmpCollector  575 | 187 - com.ca.im.data-collection-manager.core.interfaces - 20.2.1.RELEASE-238 |  | Failed to find SNMP profile for device 1112512/10.73.7.76
2021-01-22 15:52:16,584 | ERROR | adpool-thread-99 | SnmpProfilesManager              | mp.collector.SnmpProfilesManager  725 | 197 - com.ca.im.data-collection-manager.snmp - 20.2.1.RELEASE-238 |  | No SNMP profile was found for device 217610.  Profile ItemID = 804

 

 

Environment

Release : NetOps 20.2

Component : IM Data Aggregator

Cause

kahadb has gotten corrupted

Resolution

1. rename /opt/IMDataAggregator/data/broker/kahadb on the Data Aggregator

2. Restart activemq; systemctl stop activemq, then systemctl strart activemq

3. Restart the dcmd and activemq processes on the Data Collector

      systemctl stop dcmd

      systemctl stop activemq

      systemctl start dcmd

 

Additional Information

dcmd will also start activemq