PAM Appliance and Cluster Down
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PAM Appliance and Cluster Down

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Article ID: 207148

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

In PAM Cluster -> users are only able to View Passwords or Auto-Connect to devices from the primary master.

On other primary members, they see garbled (encrypted) characters when trying to view the password.

Environment

Release : 3.3.x

Component : PRIVILEGED ACCESS MANAGEMENT

Cause

The server encryption between the appliance got corrupted

Resolution

Performed the following steps:

  • Stop the cluster
  • Make sure you have a Snapshot or DB Backup on the Primary Master
  • On the Non-Primary members we did -> PAM UI >> Configuration >> Database >> Reset
  • Set's these appliances back to factory defaults and rebooted
  • When PAM comes back up:
  • PAM UI >> Configuration >> Security >>Certificates >> Set >> set certificate and reboot
  • PAM UI >> Configuration >> Clustering >> Global Settings >> "Primary Site"
  • Double checked all members listed (update if necessary)
  • Click on Clustering Page -> Save Config Locally and Save to Cluster
  • Restart Cluster.

All appliances the view passwords, auto connect, etc. worked fine after this procedure