Re-importing existing LDAP users results in missing message "All users have already been imported" for some users
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Re-importing existing LDAP users results in missing message "All users have already been imported" for some users

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Article ID: 207049

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio)

Issue/Introduction

After upgrade to 6.6 we see some discrepancy while re-importing users. When we try to re-import users for some users we get message 

"All users have already been imported" and for some user we don't get this message. 

Please note that all users for which we are getting message and not are already imported in RA.

Environment

Release : 6.6

Component : CA RELEASE AUTOMATION CORE

Cause

The users for which message is displayed and for which are not they differ as a record in DB. It may be due to fact that some users may be the migrated users and hence resulting in the discrepancy. 

What we observed during our analysis is that for the user where the message is not displayed are the one where the value of LDAP_DN attribute in the DB is empty.

Resolution

Unless the user is shown in imported Users in ROC and they are getting correct granted permission during login. This message can be ignored.

In case if you want to eradicate this message our recommendation is to remove this user and re-importing the user again align the DB record in correct format. Please note removing and re-importing user will requires to grant the permissions again for that users.