Data Center Security Windows agent upgrade fails due to pre-existing agent installation
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Data Center Security Windows agent upgrade fails due to pre-existing agent installation

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Article ID: 206980

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

When attempting to upgrade to a newer version of the Windows DCS agent, the install partially fails. The agent shows up in Control Panel, but is not functional. 

When attempting to uninstall via Control Panel, the agent appears to be uninstalled, and no agent files exist in the install directory, but when attempting to install fresh agent after Control Panel uninstall, the installer fails with a message stating that there is already an existing agent installed. 

 

Environment

Release : DCS 6.x 

Component : DCS Windows Agent 

Cause

The uninstall via Control Panel left some existing agent services or registry entries, thus preventing the agent from be upgraded or re-installed fresh. 

Resolution

If installing the same version of the pre-existing agent does not fix the issue, contact support for manual uninstall instructions.