ERROR on SOAP REQUEST to IDM

book

Article ID: 206859

calendar_today

Updated On:

Products

CA Identity Manager

Issue/Introduction

When getting the following error while try to make a SOAP Request to IDM:

Response payload:

<HTML>

    <HEAD>

        <TITLE></TITLE>

    </HEAD>

    <BODY onLoad="document.AUTOSUBMIT.submit();">This page is used to hold your data while you are being authorized for your request.

        <BR>

            <BR>You will be forwarded to continue the authorization process. If this does not happen automatically, please click the Continue button below.

                <FORM NAME="AUTOSUBMIT" METHOD="POST" ENCTYPE="application/x-www-form-urlencoded" ACTION="/siteminderagent/forms/login.fcc?TYPE=33554433&REALMOID=06-a180c4f7-178d-4d8c-ba51-e3611a3f8d8c&GUID=&SMAUTHREASON=0&METHOD=POST&SMAGENTNAME=vHWqs90rw0MWWM7Fxj2QokjDcdgZuffG799NiKmYA317f8uWDLXZFjvPF8vXMT3R&TARGET=-SM-http%3a%2f%2fhpvrdidgv02v%2eresource%2ecorp%2elcl%2fiam%2fim%2fTEWS6%2fidentityEnv">

                    <INPUT TYPE="HIDDEN" NAME="SMPostPreserve" VALUE="snUIiaVfR32u4Jnz9S2yp0XafbfrLzvl9BmrctHUvmFbcUgTQLAcC1ZpY3CjTezjd018HCQOJqaSu8yN0ef6EezmM6p+GlwHNAYG/w8GQ8GAYkTquu7WXtpwxuYbGrHum6isgXsyweXKJK6Kqynp8u6cIb4bbKfap8anB1CB7t1/met37eKyhPpbUR4deUNkcoDF/WDxPtre6vJtCh7b1LIw8E0J7Mo1GNJtRLXPgTlUI8znAP0q50AHbYcoTlICsbFQfL+StHGZ/+5yjZ9wINYy0I9Kg0CFjat06j19/ifyCXrBrfM3aZfmO1TZ9L+4imCkhlOP4CbVHTyp5Z5lRMWniuzh2tdmCnauYyjDKOLSWCeIg7nmESOk9zjzi5UBun/ZkZwDmIVcTElDnXxRek2+tdTnC96GDdkYKNo3vLb8GNN+OEw+16chBPC1Oig28gJOskMMrqc1y/mOa3VBGgUM435PpDPmo9DszU7Tf8+xmvd8GpD3bHYInsepf26f1SEGOjwBF0AkcKqbqYYX57PlXrjuaN4F2XBrT9KUWjb2i9LuYT8o6BGPhY/tph2OYrmFZVa9hZ7nUIDdYVmXgIpuZ/04vZR/UqakSvTs9HTEbIllWM845VpclKQwn7wSBm66QzAhc4taVE0jmQM+8nvyLAXz91xlxBEcheyKZ/buCL+hUQ+8jojvSwggvKrCrmFHLgETycVH+Uk5M4Yekgl0lTdpZPf7tStIpuJiuC4Bfm34bOslUhcd2PM0qrKtPZIQtY3CDK+kSwAawGuTsUjy6Y/SDQ9MHFBHWpyamW67Pl/qlZQaVg5TYb1QdXdlVp2AyRB+FD/MdYiUWd4+IVOuV58uCPy4Bv/RWpKqyk61NDIG5k//hLPedf3ZGrksnYhANQaY8fLoEfyX1SclpSoLc0C4MiW6zznyGq+sAvcwYbTEFKnJV1Uqu2b2NTlk/8M7gVQJXt+uCL/Qc97zGySclJ1VjLF2krLzNe+54RaWNW586CcjJ47tulpYXzPH1oxyNLwCRoQ5MmKdcBHbmaAU3p7aetZw6dnLM9xAyaHYousFKv7g8TLFH9+H/6ig8K15EGvlsOMaJNwdIruX/NkNC/8algJd+zqyzM6aWeXUdKRvL7Ey5uP/m6pEEN/iKwtAvhEhQJHDKcSfxIrj1SQQVQTKRUpmEp+Ioxgf8iqGoabIgatSY1PJDv1SoIzFmdhFVAIRYZ9jRhnnuEwW3gRAO6OEiP/lgHt7gGUmoVxKDHoUIz88HOL9I5tpNxAGQWQrqlMPwL0EyuPr+M8WMDkEUjJ3lHkV5N5sTB02ENNgcYYAdw636JaATWClpfYlDR0hasT8a3mYqBVCCrCg7MfDruRtvkGG1Gwb72Vmz/tY3OA7ZnttIBTJTd1SkmHGshwcI+eCvPbSA37kU1cVQhhksrZSUsNk">

                        <INPUT TYPE="SUBMIT" VALUE="Continue">

                        </FORM>

                    </BODY>

                </HTML>

Cause

This is due to SSO is using wrong authentication Scheme.  

Environment

Release : 14.3

Component : IdentityMinder(Identity Manager)

Release: 12.8

SSO

Resolution

Change Authentication Scheme to basic and then restart IDM and web agent