NCM policy violation due to Spectrum being unable to capture the Device Config - "ip device probe tracking delay"
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NCM policy violation due to Spectrum being unable to capture the Device Config - "ip device probe tracking delay"

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Article ID: 206784

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Updated On:

Products

CA Spectrum

Issue/Introduction

After upgrading Cisco Device's IOS version from 03.08.06 to 03.11.02, the following NCM Policy Violation is thrown:

Missing Line in Current Block 1

ip device probe tracking delay 10

Environment

Spectrum 10.x and 20.2.x or later

Cause

This is due to the following Cisco device command:

ip device probe tracking delay

As per Cisco advice, this command is actually hidden now by the updated firmware. To show this line from the command prompt of the device, you need to run:

sh run all

Instead of just:

sh run

 

Resolution

Spectrum NCM sends a "show running config" command to the device. The device sends back the config and NCM goes through it, line by line, to compare it with your policy settings.

It then stores the results in the SSdb.

The only way you can check for "ip device probe tracking delay" is to use something like Capture Running/Startup Config and modify the script used to do this.

When you don't select a script, the policy uses a hard-coded default. This hard coded default relies on "sh run", not "sh run all".

However, you can select the Cisco NX OS Capture_Running_Script and set it as the Capture Running Script. This will operate the same way:

Then, you can copy this script to a backup file before editing it to change the following line:

$ssh->send( "sh run" );

to

$ssh->send( "sh run all" );


Then save the changes. No other changes should be necessary, your policy will run like before, but use this script to provide the output from the device instead of the internal hard-coded one.