CABI 4.3 failed to connect SQL TLSv1.2

book

Article ID: 206710

calendar_today

Updated On:

Products

CA Unified Infrastructure Management On-Premise (Nimsoft / UIM)

Issue/Introduction

We have installed CABI probe 4.3 on UIM 20.3, it works successfully. However, after we enabled TLSv1.2 on SQL Server 2016, it failed. I saw error related to JDBC. Once we disable TLSv1.2 on SQL server, cabi can connect again. 

Environment

UIM 20.3

CABI  4.3

Resolution

The CABI 4.3 TLS 1.2 support the window 2019  with SQL Server 2016 on DB Server.

CABI 4.30 with SQL Server 2016 and Windows Server 2016.  This is supported, but only if TLS 1.2 is not enabled.    If you plan to use TLS 1.2 in this environment, you should not use Windows Server 2016 with SQL Server 2016.