Selecting a custom time range will revert and will be set to 'Yesterday', and be stuck on that value
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Selecting a custom time range will revert and will be set to 'Yesterday', and be stuck on that value

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Article ID: 206591

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Updated On:

Products

CA Infrastructure Management DX NetOps

Issue/Introduction

Selecting a custom time range will revert and will be set to 'Yesterday', and be stuck on that value

Environment

Introduced in the r20.2.5 release of DX NetOps Performance Management

Also affects the r20.2.6 release

Cause

Expected Behavior: Selecting a custom time range will be set on the page context time range
Actual Behavior: Selecting a custom time range will revert and will be set to 'Yesterday', and be stuck on that value

Steps to reproduce the error:

  1. On Dashboard launch the Select Time Range page control
  2. Use the calendar approach to select a custom time range
  3. Select the period in the past that goes across a day (24 hours)
  4. Apply the selected time range selection on the launched dialog
  5. Notice the Dashboard page show 'Yesterday' as the selected time range
  6. Modify the selected time range again by launching the Time Range page control
  7. Use the calendar approach to select a custom time range
  8. Select the period in the past that goes across a day (24 hours), something other than the previous day
  9. Apply the selected time range selection on the launched dialog
  10. Notice the Dashboard page show 'Yesterday' as the selected time range

Resolution

The fix for this problem is contained within release 20.2.7 which is fully GA as of this writing.

It's fixed per this entry from the Fixed Issues documentation.

  • Symptom:  Selecting Previous Week, Previous Month, or a Custom Time in the Time Picker incorrectly sets to Yesterday.
  • Resolution: Created a constant and increased the max range for time ranges which allows the selection of Previous Week, Previous Month, or a Custom Time.
  • (20.2.7, DE487863, 32464285)

The only known work around is to edit the URL by hand to specify a Custom Time Range.

This is a sample URL for a Dashboard against the Last Hour default Time Frame option.

  • http://<PC_HostName>:8181/pc/desktop/page?timeRange=0&sid=&endTime=2021-02-04+09%3A58&startTime=2021-02-04+08%3A58&mn=3&pg=2000060&globalsearchtext=&GroupID=1&parentid=2000066

This is the same Dashboard set to a Custom Time Range.

  • http://<PC_HostName>:8181/pc/desktop/page?timeRange=-1&sid=&endTime=2021-02-02+09%3A58&startTime=2021-02-01+08%3A58&mn=3&pg=2000060&globalsearchtext=&GroupID=1&parentid=2000066

The Custom Time Range set in that URL sample runs between:

  • Start: Feb 1, 2021 @ 8:58 AM
  • End: Feb 2,2021 @ 9:58 AM

The values important when manually editing the Time Range in the Dashboard URL are:

  • timeRange: always use -1 which is the reference for a Custom Time Range.
  • startTime and endTime
    • Both are the same format.
    • Use the format shown above:
      • startTime=2021-02-01+08%3A58
    • This breaks down to:
      • startTime=<year>-<month>-<day>+<hour>%3A<minutes>
    • The %3A is the URL translation for the ':' colon character in the time specified. Do not change it.

For example to modify the URL for a Custom Time Range between Noon on December 1st, 2020 and Noon on December 31st, 2020 we'd have startTime and endTime values as follows:

  • startTime=2020-12-01+12%3A00
  • endTime=2020-12-31+12%3A00

The final URL would look this:

  • http://<PC_HostName>:8181/pc/desktop/page?timeRange=-1&sid=&endTime=2020-12-31+12%3A00&startTime=2020-12-01+12%3A00&mn=3&pg=2000060&globalsearchtext=&GroupID=1&parentid=2000066