I/O Error: Connection refused (Connection refused) when uploading Gateway patch
search cancel

I/O Error: Connection refused (Connection refused) when uploading Gateway patch

book

Article ID: 206512

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

When uploading a patch to the Gateway, we receive this message:

You have chosen to upload the patch named
"/home/ssgconfig/CA_API_PlatformUpdate_64bit_vKernel-2018-10-05.L7P"
Press [Enter] to continue


Please wait while the patch is uploaded ...
I/O Error: Connection refused (Connection refused)


There was an error while uploading the patch.
Press [Enter] to continue

 

Environment

Release : 9.2

Component : API GATEWAY

Cause

The process controller needs to be running when applying a patch.

The documentation says that you need to stop the Gateway so some clients will run 'service ssg stop'.

This stops the Gateway AND the process controller.

Resolution

You need to stop the Gateway using the menu:

Select option 2 (Display Layer 7 Gateway configuration menu).
Select option 7 (Manage Layer 7 Gateway status).
Press Enter and then select the option to stop the Gateway.
Return to the Gateway main menu