Workflow tasks not showing on some closed Change Orders in Service Desk Manager
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Workflow tasks not showing on some closed Change Orders in Service Desk Manager

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Article ID: 206494

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

For some reason, some of the workflows are no longer showing up on our change detail screen.  It works fine for opened ones but not closed ones.

Error in F12 Console when loading the workflow task in a change order:
Uncaught SyntaxError: Unexpected token '=='

Response shows:
bhvtpl_ctr++; if(==reopen_id){ has_reopen=true; }

Environment

Release : 17.1

Component : SERVICE DESK MANAGER

Cause

There is an empty behavior in a workflow causing this issue.

Resolution

1. Log into SDM > Administration > Service Desk > Change Order > Categories

2. Click on the category that is being used by the Change Order with the problem

3. Click on each workflow task and identify the empty behavior 

4. Right-click on the empty behavior > Delete