How to find what values that we should specify to LDAP options to integrate SDM with Active Directory
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How to find what values that we should specify to LDAP options to integrate SDM with Active Directory

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Article ID: 206448

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

When integrated Service Desk Manager (SDM) with Windows Active Directory (AD), we need to install and setup LDAP options. This document helps to find how to find what values need to be specified as 'LDAP_DN' and 'LDAP_SEARCH_BASE' options.

Environment

Windows

Cause

When LDAP integration does not work, the LDAP option settings, 'LDAP_DN' and 'LDAP_SEARCH_BASE' are likely to have wrong setting. 

Resolution

Please follow the below steps, and check what values need to be specified for the LDAP options at your site. 

1. On an Active Directory server, open the Command Prompt and run the following command.

ldifde -f ldapusers.txt -s <domain controller server name> -r "(objectClass
=user)" -b administrator <domain name> <administrator password>

2. Open the generated file "ldapusers.txt" in the Notepad. You will be able to see the first line shows "dn:".
e.g. CN=Administrator,CN=Users,DC=<domain name>,DC=<domain name e.g. "com">

3. Copy the line you see on the step 2 to the Service Desk Option 'LDAP_DN' and save the change.

4. Copy the same line to the option 'LDAP_SEARCH_BASE' and remove "CN=Administrator". Save the change.

5. Restart the Service Desk service to take effect the changes. 

Additional Information

Troubleshooting LDAP Configuration with CA SDM

How to integrate CA SDM with LDAP