Patches not applying due to error: ""... executed with exit code 5 (0x5)- 'Access is denied'
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Patches not applying due to error: ""... executed with exit code 5 (0x5)- 'Access is denied'

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Article ID: 206440

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Updated On:

Products

IT Management Suite Client Management Suite Patch Management Solution

Issue/Introduction

A few patches are not being installed and the agent.log files show errors like the following:

Severity: 1
Date: 12/10/2020 10:10:01 PM
Tick Count: 270768945
Host Name: <hostname>
Process: AeXPatchDeployment.exe (3796)
Thread: 4740
Module: AeXPatchDeployment.exe
Source: Deployment Engine
Description: 
  Command [STDeploy.exe package="C:\ProgramData\Symantec\Patch\staging\deploy-package.zip" sandboxesDir="C:\ProgramData\Symantec\Patch" logsDir="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47FB3265-E4AC-D52F-491D-2A4EB66E37EE}\cache" patchStore="C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{47FB3265-E4AC-D52F-491D-2A4EB66E37EE}\cache"] executed with exit code 5 (0x5)- 'Access is denied'

On another system the agent.logs included the following errors:

Severity: 1
Date: 12/21/2022 10:52:50 AM
Tick Count: 559062
Host Name: win8129562
Process: AeXPatchDeployment.exe (272)
Thread: 4400
Module: AeXPatchDeployment.exe
Source: FileOperation
Description: 
  Failed to perform file operation 'delete' on 'C:\ProgramData\Symantec\Patch\staging\AexDeploymentEventsHandler.dll' with retries: Access is denied (0x00000005)

Severity: 2
Date: 12/21/2022 10:52:50 AM
Tick Count: 559062
Host Name: <hostname>
Process: AeXPatchDeployment.exe (272)
Thread: 4400
Module: AeXPatchDeployment.exe
Source: RemoveDirectoryTree
Description: 
  Cannot delete file 'C:\ProgramData\Symantec\Patch\staging\AexDeploymentEventsHandler.dll', error: Access is denied (0x00000005)

Severity: 1
Date: 12/21/2022 10:53:20 AM
Tick Count: 589078
Host Name: <hostname>
Process: AeXPatchDeployment.exe (272)
Thread: 4400
Module: AeXPatchDeployment.exe
Source: Deployment Engine
Description: 
  Unable to create folder 'C:\ProgramData\Symantec\Patch\staging', this folder already exists

Severity: 1
Date: 12/21/2022 10:53:20 AM
Tick Count: 589078
Host Name: <hostname>
Process: AeXPatchDeployment.exe (272)
Thread: 4400
Module: AeXPatchDeployment.exe
Source: Deployment Engine
Description: 
  Cannot create folders structure necessary for deployment. Error: 0B7

Severity: 1
Date: 12/21/2022 10:53:20 AM
Tick Count: 589093
Host Name: <hostname>
Process: AeXPatchDeployment.exe (272)
Thread: 4400
Module: AeXPatchDeployment.exe
Source: Deployment Engine
Description: 
  Deployment failed. Status is  183 (0xB7).

Environment

Patch Management 8.5 RU4, 8.6 RU3

 

Cause

The "C:\ProgramData\Symantec\Patch\staging\" folder is used as needed depending on the patch(es) to be installed. It would need to be available to the System account for use (permissions) and anti-virus products need to allow operations to happen there.

Resolution

Confirmed that these errors were caused by the settings of the anti-virus product being used.