GSS 3.3 RU4 Reboot looping on Win10Iot 2019 LTSC
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GSS 3.3 RU4 Reboot looping on Win10Iot 2019 LTSC

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Article ID: 206432

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

When the customer assigns from the GSS Console a "reboot" task to Client machines with "Win10Iot 2019 LTSC",  "reboot" task completes on the client machine and them loops (restart again and again and again)

The customer tested with both Writefilter enabled and disabled.

The customer logs show two points different what we usually expect to see:

1.  From client logs.

a) After the client machine seems to have finished the task

Sent Message - [Fri Oct 9 11:11:54 2020.963]
Reply=UpdateComputer
ID=5000192
Boot=Production
Server-Name=EXAMPLE-AI-DP-001
Result=Success
Work-To-Do=No
DSVersion=13.3.3115
User-Info-Interval=60
UpdateSettings=No

Sent Message - [Fri Oct 9 11:11:54 2020.963]
Request=JobStatus
Schedule-ID=100001623
Task-Sequence-ID=0

Sent Message - [Fri Oct 9 11:11:54 2020.963]
Request=TimeSync
UTC-Time=2020-10-09T09:11:54Z

b) It goes back and seems to request the same job again:

Recv Message - [Fri Oct 9 11:11:54 2020.977]
Reply=JobStatus
Schedule-ID=None

Sent Message - [Fri Oct 9 11:12:00 2020.035]
Request=WorkToDo
Schedule-ID=100001623
Task-Sequence-ID=0
Allow-Defer=3
Reboot=Reboot
Task-Type=Reboot
Boot-Env=Production
Target-Boot-Env=Production
Forced=Yes

 

2. from axengine logs:

After it received the success status for the "reboot" task, it seems like it is re-scheduling the same job again:

1324-Processing scheduled event: EVENT_ID=2001096; NEXT_TASK_SEQ=0; STATUS_CODE=0; COMPUTER_ID=5000192

1324-Socket: Sent data to computer 5000192 (10.138.32.41), socket (2432).1324-Socket: Sent data to computer 5000192 (10.10.32.41), socket (2432). Request=WorkToDo Schedule-ID=100001623 Task-Sequence-ID=0 Allow-Defer=3 Reboot=Reboot Task-Type=Reboot Boot-Env=Production Target-Boot-Env=Production Forced=Yes

 

The initial workaround used by the customer was:

Run script task with "Shutdown /r"

Environment

GSS 3.3 RU4

Cause

The problem only exists with HP OEM OS installation. Something to do with HP OEM OS Writefilter. When we install clean Windows 10 Enterprise LTSC from MS media, the problem is not observed.

HpT740 with Windows 10 Enterprise LTSC x64
OEM image Win10Iot 2019 LTSC 19WWGTAN601 Dutch (Aug 2019) voor T740 OS Win10-64

Resolution

As the issue was only with HP OEM OS, a way to get this issue worked out by:

  1. Excluding the c:\HPwmtemp folder from the HpWriteFilter.
    On a HP T740 with a HpWriteFilter enabled, the %temp% and the %TMP% variables are configured to z:\Temp. Z:\Temp is a subset of the folder c:\HPWMTemp. GSS uses the %TEMP% to write the jobstatus files. Every time after a reboot job is done, the HpWriteFilter clears the status files that the job is done in the %temp% folder. This results in a looping job.

This is not really product problem but rather how HP handled writefilter. If we disabled Windows own Writefilter then HP one was still active and working.