WASP probe fails to start after deploying UIM 20.3.2
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WASP probe fails to start after deploying UIM 20.3.2

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Article ID: 206240

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Wasp probe on the OC robot fails to start after the deploying ump_operatorconsole_2.08_HF2

Error in wasp.log

ERROR [Catalina-utility-1, org.apache.catalina.startup.ContextConfig] beforeStart() Exception fixing docBase for context [/operatorconsole_portlet]
ERROR [Catalina-utility-1, org.apache.catalina.startup.ContextConfig] java.util.zip.ZipException: error in opening zip file

Environment

Release : UIM 20.3

Component : Wasp

Cause

Corrupt import of ump_operatorconsole_2.08_HF2.zip

Resolution

1. Check the ..probes\service\wasp\webapps\operatorconsole_portlet.war file. (Size should be 204,461 KB)

2. If operatorconsole_portlet.war file is incorrect, download the ump_operatorconsole_2.08_HF2.zip again from the CA Unified Infrastructure Management Hotfix Index page

https://support.broadcom.com/external/content/release-announcements/CA-Unified-Infrastructure-Management-Hotfix-Index/7233

3. Delete the existing ump_operatorconsole_2.08_HF2 package from the UIM Archive
4. Import the newly downloaded ump_operatorconsole_2.08_HF2 package to the UIM Archive

5. Deactivate wasp on the OC robot

6. Delete the ..\probes\service\wasp\work folder if present

7. Deploy ump_operatorconsole_2.08_HF2 and confirmed the probes\service\wasp\webapps\operatorconsole_portlet.war file size

8. Activate the wasp probe

Additional Information

General check for wasp failed issues:

 

Follow the below step:-

1. Check the path to certificate.pem in the robot.cfg on the UMP robot from:

2. Rename work folder

3. go to webapps folder

Move all sub folders to other location.

DO NOT REMOVE .war files

4. Delete the C:\Windows\Temp\liferay 

5. Deactivate & Activate the wasp probe