When attempting to run reports for NFA based metrics for an interface, many are failing

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Article ID: 206205

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps CA Network Flow Analysis (NetQos / NFA)

Issue/Introduction

In my IP Performance context page for an interface, the reports either show No Data to Display or some have a query failed message.  The router is showing flow data in NFA.

 

These 3 views have query failed.  The other flow-based views just say No Data to Display.

 

Top Hosts Pie (From)

Query failed. See the logs for details. (Query ID: aea38f41-04ef-4e1e-b2ed-367a9bee077a)

 

Top Hosts Pie (To)

Query failed. See the logs for details. (Query ID: b65909a7-4f21-4d25-a1c4-a5e6a69ded03)

 

Top Summary Pie (Total)

Query failed. See the logs for details. (Query ID: 02df82d7-d4bb-4ca0-870d-803b9ba6a7fb)

Cause

NFA and Performance Center's data is misaligned causing Performance Center to request ids that do not exist.  The following errors can be seen within the PCService.log in Performance Center:

ERROR | qtp17213345-9859         | $date $time | com.ca.im.portal.plugins.rib.models.RIBTableModel                
      | RIB query failed
          Model ID/Type: {102028/RIBTableModel}
          Result status: {FAILED}
          Query ID: {b65909a7-4f21-4d25-a1c4-a5e6a69ded03}
          RIB source URL: {http://NFA_HOSTNAME:8681/NFARS/ribsource/rib/soap?wsdl}
          Query: {SELECT .Host.Host, .Host.Name, .Host.BytesIn, .LocalInterfaceID FROM CA.ReporterAnalyzer.RAWSParameters WHERE .InterfaceID = 1116 AND .StartTime = 1613118720 AND .EndTime = 1650122320 AND .Measurement = 'Bytes' AND .LimitCount = 50 AND .Direction = 'In' AND .ProtocolID = 24 HAVING (.RAWebCall = 'HostSummary')}
          Reason: {{
Error occurred while running a RIB query on SQL RIB source.
  Possible reason: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0

Environment

All supported releases of Performance Center and Network Flow Analysis

Resolution

Perform a FULL resynchronization with the NFA data source within the Performance Center GUI.  This capability is within the Administration > Data Sources > Data Sources menu.