Operator Console gives 404 error after upgrade
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Operator Console gives 404 error after upgrade

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Article ID: 206172

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Operator console  inaccessible after upgrade. 

Received an error: "HTTP status 404  - Not Found with message " The requested resource [/operatorconsole_portlet/] is not available

Description: The origin server did not find a current representation for the target resource or is not willing to disclose that one exists"

Rest API test verified  all calls to the API after login resulted in 401 error. Logs showed "Invalid or Missing Header".

 

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Environment

Release : 20.x

Component : UIM - OPERATOR CONSOLE

Cause

This issue was  because the  adminconsole war file in the install folders was unable to extract all the contents.

We were suspecting the issue could be with the size of the header or some encoding/decoding issue during the transmits. This may have been triggered by the Customer network unable to transmit the Request Headers to the OC Server.

Resolution

1)Manually deploying ump_adminconsole.zip from archive to Primary Hub server resolved the issue. We suspect this is primarily due to the corrupt software running on the server.     

2) Requested that customer network security team address network related issues affecting header

 

Additional Information

We replaced UMP/WASP common JARs used for authentication with OC 20.32 version deliverables but the issue still occurred. We restored the original JAR files from UMP_20.32_HF1. 
We then verified the OC API from Swagger UI by passing a small Authorization header from the Customer browser. This is also resulting in the same "Invalid or Missing Header" error message in WASP 
Logs. Header values are discarded in the Client system before sending requests to OC.

 

Additional Notes:

UIM - OC shows error 404 after installing 20.3.3 October Patch (broadcom.com)