Issue on artifact distribution
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Issue on artifact distribution

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Article ID: 206103

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Updated On:

Products

CA Release Automation - Release Operations Center (Nolio) CA Release Automation - DataManagement Server (Nolio)

Issue/Introduction

Hello,

Sometime, there is an issue with the artifact distribution. It seems ok on the pre-deployment step but the artefact stay at 0bit and the unzip step is failed-pause.

After check, the ZIP file is OK on the NES

On the server, we have this result :

./APPLICATION_ARTIFACTS_ZIP/amh-commons-amh-publisher/4.0.7-01:
total 0
-rw-r--r-- 1 root root 0 Oct  8 14:36 amh-commons-amh-publisher-4.0.7-01.zip

./APPLICATION_ARTIFACTS_ZIP/amh-commons-snape/4.0.7-13:
total 14800
-rw-r--r-- 1 root root 15153891 Oct  8 14:36 amh-commons-snape-4.0.7-13.zip

 

The Diskspace is checked and there is no issue with that.

Environment

Release : 6.6, 6.7 or higher

Component : CA RELEASE AUTOMATION CORE

Cause

  • The problem is that the NES thinks files_registry/2EDF45728128869CA76F6E2644A94A54 has size zero, even though it was successfully downloaded to that NES and even uploaded from that NES to other nodes.
  • The artifact you are trying to transfer from logs we suspect is approx 1.2G in size
2020-10-08 14:34:32,547 [New I/O client worker #1-3] DEBUG (com.nolio.nimi.filetransfer.impl.AbsFileTransferWorker:394) - GETTER_2EDF45728128869CA76F6E2644A94A54 received file info [FileInfoImpl{fileId=fid:2EDF45728128869CA76F6E2644A94A54, localPath=files_temp\nlo1325895694096932615file, name='2EDF45728128869CA76F6E2644A94A54', size=1214339300, lastModified=1602160444341, lastTouched=1602160472546}].

2020-10-08 14:34:32,547 [OutboundConnectionsImpl-1090198] DEBUG (com.nolio.nimi.filetransfer.impl.FileTransferManagerImpl:261) - Sent response for file FileInfoImpl{fileId=fid:2EDF45728128869CA76F6E2644A94A54, localPath=files_temp\nlo1325895694096932615file, name='2EDF45728128869CA76F6E2644A94A54', size=1214339300, lastModified=1602160444341, lastTouched=1602160472546} to node `nid:es_********`.

2020-10-08 14:34:32,550 [New I/O client worker #1-1] DEBUG (com.nolio.nimi.filetransfer.impl.AbsFileTransferWorker:91) - SENDER_2EDF45728128869CA76F6E2644A94A54_es_******* is setting next chunk offset for FileInfoImpl{fileId=fid:2EDF45728128869CA76F6E2644A94A54, localPath=files_temp\nlo1325895694096932615file, name='2EDF45728128869CA76F6E2644A94A54', size=1214339300, lastModified=1602160444341, lastTouched=1602160472546} to 0.

2020-10-08 14:34:32,551 [FileTransferWorker-228358] DEBUG (com.nolio.nimi.filetransfer.impl.AbsFileTransferWorker:272) - SENDER_2EDF45728128869CA76F6E2644A94A54_es_******** started sending file FileInfoImpl{fileId=fid:2EDF45728128869CA76F6E2644A94A54, localPath=files_temp\nlo1325895694096932615file, name='2EDF45728128869CA76F6E2644A94A54', size=1214339300, lastModified=1602160444341, lastTouched=1602160472546}
    • ./files_cache - files_cache is the cache directory and stays there until it gets evicted due to storage limitations. Files in the cache directory are reused instead of re-downloading them from a source.
    • Storage limitation on files_cache is not something related to actual disk space available on server, rather it is limit from application configuration controlled from nimi_config.xml file. 

Resolution

1: Stop the NES service identified

2: Clear the content of files_cache, files_reigstry and files_temp folder

3: Open the nimi_config.xml file of NES's and modify the below configuration

Default value 
           1048576 # it's in KB
New Value
           2048576 #it's in KB ~ 2GB


Note: If you think some other files/artifact can be of greater than 2GB you can try 3048576 also.

4: Start the NES service

5: Try to run the deployment again.