Database plugin cannot connect
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Database plugin cannot connect

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Article ID: 206067

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Updated On:

Products

CA Workload Automation DE - Business Agents (dSeries) CA Workload Automation DE DSERIES- SERVER CA Workload Automation DE - System Agent (dSeries) CA Workload Automation DE - Scheduler (dSeries)

Issue/Introduction

DB plugin cannot connect, the agent itself is connected ok but the db plugin is not working. Have uninstalled and reinstalled agent but still cannot connect

Environment

Release : 12.1

Component : CA WORKLOAD AUTOMATION DE (DSERIES)

Cause

The agent logs show that the Database plugin is started and initialized but DE Server cannot connect to the agent plugin due to some network connectivity issues. 

The DE Server tracelog logged connection exception like the below;

Caused by: java.net.ConnectException: Connection refused (Connection refused)

20210105 19:09:57.540 [essential] [INFO] RMI TCP Connection(39454)-XX.XX.XXX.XXX: [2021-01-05_19:09:57.540] Ping failure: java.net.ConnectException: Connection refused (Connection refused) while pinging agent AGENT007; assuming down

Resolution

The agent port, address, and encryption must be the same for both System agent and Database plugin in Agent definition Admin -> Topology in the Desktop Client.